Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

Циклы в языке 1С 8.3, 8.2 (в примерах)

См. урок №1 и урок №2 для начинающих по циклам в языке 1С

Процедура КнопкаВыполнитьНажатие(Кнопка)
 
    /// Как организовать цикл в 1с 8.3, 8.2
 
    // Для Цикл
    Для Счетчик = 1 По 5 Цикл
        Сообщить(Счетчик); // 1 2 3 4 5
    КонецЦикла;
 
    // Для Каждого Цикл
 
    Дни = Новый Массив();
    Дни.Добавить("Понедельник");
    Дни.Добавить("Вторник");
    Дни.Добавить("Среда");
 
    Для Каждого Элемент Из Дни Цикл
        Сообщить(Элемент); // Понедельник Вторник Среда
    КонецЦикла;
 
    // Пока Цикл
    Счетчик = 0;
    Пока Счетчик < Дни.Количество() Цикл        
        Сообщить(Дни[Счетчик]); // Понедельник Вторник Среда
        Счетчик = Счетчик + 1;     
    КонецЦикла;     
 
    /// Как организовать обратный цикл в 1с 8.3, 8.2     
 
    Счетчик = Дни.Количество() - 1;     
    Пока Счетчик >= 0 Цикл
        Сообщить(Дни[Счетчик]); // Среда Вторник Понедельник
        Счетчик = Счетчик - 1;
    КонецЦикла;
 
    /// Как прервать цикл в 1с 8.3, 8.2
 
    Для Счетчик = 1 По 5 Цикл
        Если Счетчик > 2 Тогда
            Прервать;
        КонецЕсли;
        Сообщить(Счетчик); // 1 2
    КонецЦикла;
 
    /// Как принудительно продолжить цикл в 1с 8.3, 8.2
 
    Для Счетчик = 1 По 5 Цикл
        Если Счетчик <> 3 Тогда
            Продолжить;
        КонецЕсли;
 
        Сообщить(Счетчик); // 3
    КонецЦикла;
 
КонецПроцедуры

Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

Циклы в языке 1С 8.3, 8.2 (в примерах)

С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.