Есть массив из n элементов, необходимо найти максимальный элемент массива в 1с 8.3, 8.2

См. также Массивы в языке 1С 8 (в примерах)

МассивЧисел = Новый Массив(3);
МассивЧисел[0] = 234;
МассивЧисел[1] = 100;
МассивЧисел[2] = 54;

ИндексМаксимальногоЭлемента = -1;
ЗначениеМаксимальногоЭлемента = -Pow(2, 31); // Значение, заведомо меньшее любого элемента в массиве.

Для Индекс = 0 По МассивЧисел.Количество() - 1 Цикл
    Если МассивЧисел[Индекс] > ЗначениеМаксимальногоЭлемента Тогда
        ЗначениеМаксимальногоЭлемента = МассивЧисел[Индекс];
        ИндексМаксимальногоЭлемента = Индекс;
    КонецЕсли;
КонецЦикла;

Если ИндексМаксимальногоЭлемента >= 0 Тогда
    Сообщить("Значение максимального элемента равно " +
        Строка(ЗначениеМаксимальногоЭлемента) +
        " . Его индекс в массиве равен " +
        Строка(ИндексМаксимальногоЭлемента)
    );
КонецЕсли;
С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.