Как найти значение в многомерном массиве в 1С 8.3, 8.2

См. также Массивы в языке 1С 8 ( в примерах)

МассивРастений = Новый Массив(2);
МассивРастений[0] = "Ромашка";
МассивРастений[1] = "Роза";

МассивЖивотных = Новый Массив(3);
МассивЖивотных[0] = "Ёжик";
МассивЖивотных[1] = "Жираф";
МассивЖивотных[2] = "Слон";

МассивОбщий = Новый Массив(2);
МассивОбщий[0] = МассивРастений;
МассивОбщий[1] = МассивЖивотных;

Для Индекс0 = 0 По МассивОбщий.Количество() - 1 Цикл
    Для Индекс1 = 0 По МассивОбщий[Индекс0].Количество() - 1 Цикл

        Если МассивОбщий[Индекс0][Индекс1] = "Ёжик" Тогда
            Сообщить("Ёжик найден в многомерном массиве!");
        КонецЕсли;

    КонецЦикла;
КонецЦикла;
С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.