Почему возникает ошибка "Процедура или функция с указанным именем не определена"?

оглавлениеПочему не получается войти в школу под своим логином и паролем?

Оформляйте ваш код красиво!

Я не устаю обращаться к ученикам с призывом следить за оформлением кода.

Поверьте это очень важно! Во многом оформление кода характеризует вас как специалиста (в настоящем или будущем). Хорошего программиста сразу видно в первую очередь по тому как он оформляет свой код.

Не буду давать каких-то догм и прямых установок, но у вас в процессе обучения должен сформироваться свой стиль оформления, чтобы вам легко и приятно было читать свои программы.

Остановлюсь на основных моментах:

Сумма=1+2*3; // некрасиво, не хватает пробелов
Сумма = 1 + 2 * 3; // КРАСИВО
 
Число = (10); // некрасиво, зачем тут вообще скобки?
Число = 10; // КРАСИВО
 
Число = "50"; // некрасиво и неправильно, зачем для числа кавычки?
Число = 50; // КРАСИВО И ПРАВИЛЬНО
 
если 1 > 2 тогда // некрасиво, имена команд написаны с маленькой буквы
конецесли;
 
Если 1 > 2 Тогда // КРАСИВО
КонецЕсли;
 
суммачисла = 25; // некрасиво, в имени слова "слепёшены"
СуммаЧисла = 25; // КРАСИВО
 
Числа[А-1]=10; // некрасиво, не хватает пробелов
Числа[А - 1] = 10; // КРАСИВО
 
А = 1; Б = 2; // некрасиво, два присваивания на одной строке
 
А = 1; // КРАСИВО
Б = 2;
 
Если А = 2 Тогда
Сообщить("Привет"); // некрасиво, не хватает отступа
КонецЕсли;
 
Если А = 2 Тогда
    Сообщить("Привет"); // КРАСИВО
КонецЕсли;
Почему возникает ошибка "Процедура или функция с указанным именем не определена"?

оглавлениеПочему не получается войти в школу под своим логином и паролем?