Перечисления в языке 1С 8.3, 8.2 (в примерах)

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

<<< Документы Константы Перечисления РегистрыБухгалтерии
<<< РегистрыНакопления РегистрыСведений Справочники

Полный синтаксис (нажмите, чтобы раскрыть)

/// Как вывести все значения перечисления в 1с 8.3, 8.2
 
Процедура ВывестиВсеЗначенияПеречисления()
    АмортизационныеГруппы = Перечисления.АмортизационныеГруппы;
 
    // первый способ
    Для Каждого Группа Из АмортизационныеГруппы Цикл
        Сообщить(Группа);
    КонецЦикла;
 
    // второй способ
    Для Индекс = 0 По АмортизационныеГруппы.Количество() - 1 Цикл
        Сообщить(АмортизационныеГруппы.Получить(Индекс));
    КонецЦикла;
КонецПроцедуры
 
/// Как открыть форму списка значений перечисления в 1с 8.3, 8.2
 
&НаКлиенте
Процедура ФормаСпискаЗначенийПеречисления()
    ОткрытьФорму("Перечисление.АмортизационныеГруппы.ФормаСписка");
КонецПроцедуры
 
/// Как открыть форму выбора значений перечисления в 1с 8.3, 8.2
 
&НаКлиенте
Процедура ФормаВыбораЗначенийПеречисления()
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ПослеВыбораПеречисления",
        ЭтотОбъект);
    ОткрытьФорму("Перечисление.АмортизационныеГруппы.ФормаВыбора",,,,,,
        ОповещениеОЗакрытии);
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеВыбораПеречисления(РезультатЗакрытия,
    ДополнительныеПараметры) Экспорт
 
    Если ЗначениеЗаполнено(РезультатЗакрытия) Тогда
        Сообщить(РезультатЗакрытия);
    КонецЕсли;
КонецПроцедуры

Перечисления в языке 1С 8.3, 8.2 (в примерах)

<<< Документы Константы Перечисления РегистрыБухгалтерии
<<< РегистрыНакопления РегистрыСведений Справочники

С уважением, (школа 1С программистов).



Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться: