Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

<<< Документы Константы Перечисления РегистрыБухгалтерии
<<< РегистрыНакопления РегистрыСведений Справочники

Перечисления в языке 1С 8.3, 8.2 (в примерах)

Описание (нажмите, чтобы раскрыть)
/// Как вывести все значения перечисления в 1с 8.3, 8.2
 
Процедура ВывестиВсеЗначенияПеречисления()
    АмортизационныеГруппы = Перечисления.АмортизационныеГруппы;
 
    // первый способ
    Для Каждого Группа Из АмортизационныеГруппы Цикл
        Сообщить(Группа);
    КонецЦикла;
 
    // второй способ
    Для Индекс = 0 По АмортизационныеГруппы.Количество() - 1 Цикл
        Сообщить(АмортизационныеГруппы.Получить(Индекс));
    КонецЦикла;
КонецПроцедуры
 
/// Как открыть форму списка значений перечисления в 1с 8.3, 8.2
 
&НаКлиенте
Процедура ФормаСпискаЗначенийПеречисления()
    ОткрытьФорму("Перечисление.АмортизационныеГруппы.ФормаСписка");
КонецПроцедуры
 
/// Как открыть форму выбора значений перечисления в 1с 8.3, 8.2
 
&НаКлиенте
Процедура ФормаВыбораЗначенийПеречисления()
    ОповещениеОЗакрытии = Новый ОписаниеОповещения("ПослеВыбораПеречисления",
        ЭтотОбъект);
    ОткрытьФорму("Перечисление.АмортизационныеГруппы.ФормаВыбора",,,,,,
        ОповещениеОЗакрытии);
КонецПроцедуры
 
&НаКлиенте
Процедура ПослеВыбораПеречисления(РезультатЗакрытия,
    ДополнительныеПараметры) Экспорт
 
    Если ЗначениеЗаполнено(РезультатЗакрытия) Тогда
        Сообщить(РезультатЗакрытия);
    КонецЕсли;
КонецПроцедуры

Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

<<< Документы Константы Перечисления РегистрыБухгалтерии
<<< РегистрыНакопления РегистрыСведений Справочники

Перечисления в языке 1С 8.3, 8.2 (в примерах)