Процедуры в языке 1С 8.3, 8.2 (в примерах)

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

См. урок №1 и урок №2 для начинающих по процедурам

Полный синтаксис (нажмите, чтобы раскрыть)
/// Как передать в процедуру параметр по ссылке в 1с 8.3, 8.2
 
Процедура П1(ПараметрПереданныйПоСсылке)
 
    // изменяем значение и внутри и снаружи
    ПараметрПереданныйПоСсылке = 25;
 
КонецПроцедуры
 
/// Как передать в процедуру параметр по значению в 1с 8.3, 8.2
 
// возможно только для простых типов (число, строка, дата, ... )
 
Процедура П2(Знач ПараметрПереданныйПоЗначению)
 
    // изменяем значение только внутри процедуры
    ПараметрПереданныйПоЗначению = 25;
 
КонецПроцедуры
 
/// Как передать в процедуру массив по значению в 1с 8.3, 8.2
 
// это можно сделать только через создание копии массива
 
Процедура П3(Параметр)
 
КонецПроцедуры
 
Процедура П4()
    Числа = Новый Массив();
 
    КопияЧисел = Новый СписокЗначений;
    КопияЧисел.ЗагрузитьЗначения(Числа);
 
    П3(КопияЧисел.ВыгрузитьЗначения());
КонецПроцедуры
 
/// Как для параметра процедуры установить значение
/// по умолчанию в 1с 8.3, 8.2
 
Процедура П5(Имя = "Сергей", Фамилия, Отчество = "не задано")
КонецПроцедуры
 
Процедура П6()
    П5("Вадим", "Иванович", "Сидоров"); // Вадим Иванович Сидоров
    П5("Вадим", "Иванович"); // Вадим Иванович не задано
    П5(, "Иванович"); // Сергей Иванович не задано
    П5(,,); // Сергей Неопределено не задано
КонецПроцедуры
 
/// Как в процедуре объявить локальные переменные в 1с 8.3, 8.2
 
Процедура П7()
    Перем пр1, пр2; // объявляем в самом начале
КонецПроцедуры
 
/// Как сделать процедуру доступной из других модулей в 1с 8.3, 8.2
 
Процедура П8() Экспорт
КонецПроцедуры
 
/// Как вернуть значение из функции в 1с 8.3, 8.2
 
Функция Ф1()
    Возврат 1;
КонецФункции
 
Процедура КнопкаВыполнитьНажатие(Кнопка)
КонецПроцедуры

Процедуры в языке 1С 8.3, 8.2 (в примерах)

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

С уважением, (школа 1С программистов).



Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.