РазложитьСтрокуВМассивПодстрок

  оглавление  ПроверитьРегистрационныйНомерПФР

ПроверитьКодыИФНС (1С 8.3, 8.2)

Функция проверяет на корректность коды налоговых инспекций, перечисленные через запятую.

Функция ПроверитьКодыИФНС(Знач Значение) Экспорт
 
    КодыИФНС = СокрЛП(Значение);
 
    МассивКодов = РазложитьСтрокуВМассивПодстрок(КодыИФНС);
 
    Для Каждого КодСтрока Из МассивКодов Цикл
 
        КодСтрока = СокрЛП(КодСтрока);
        Если СтрДлина(КодСтрока) <> 4 Тогда
            Возврат Ложь;
        КонецЕсли;
 
        Если Не ПопыткаПеревестиВЧисло(КодСтрока) Тогда
            Возврат Ложь;
        КонецЕсли;
 
    КонецЦикла;
 
    Возврат Истина;
 
КонецФункции
С уважением, (школа 1С программистов).



Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:



РазложитьСтрокуВМассивПодстрок

  оглавление  ПроверитьРегистрационныйНомерПФР