ПроверитьРасчетныйСчет

оглавлениеПроверитьСНИЛС

ПроверитьКорреспондентскийСчет (1С 8.3, 8.2)

Функция осуществляет проверку строки с корреспондентским счетом банка на корректность. Вторым параметром передаётся БИК банка.

Функция ПроверитьКорреспондентскийСчет(Знач Значение, Знач БИК) Экспорт
 
    Счет = СокрЛП(Значение);
 
    Если
        СтрДлина(Счет) <> 20 Или
        Не ПопыткаПеревестиВЧисло(Счет)
    Тогда
        Возврат Ложь;
    КонецЕсли;
 
    Возврат ПроверитьСчет("0" + Сред(БИК, 5, 2) + Счет);
 
КонецФункции
 
Функция ПроверитьСчет(Строка)
 
    Коэффициенты = Новый Массив(23);
    Коэффициенты[0] = 7;
    Коэффициенты[1] = 1;
    Коэффициенты[2] = 3;
    Коэффициенты[3] = 7;
    Коэффициенты[4] = 1;
    Коэффициенты[5] = 3;
    Коэффициенты[6] = 7;
    Коэффициенты[7] = 1;
    Коэффициенты[8] = 3;
    Коэффициенты[9] = 7;
    Коэффициенты[10] = 1;
    Коэффициенты[11] = 3;
    Коэффициенты[12] = 7;
    Коэффициенты[13] = 1;
    Коэффициенты[14] = 3;
    Коэффициенты[15] = 7;
    Коэффициенты[16] = 1;
    Коэффициенты[17] = 3;
    Коэффициенты[18] = 7;
    Коэффициенты[19] = 1;
    Коэффициенты[20] = 3;
    Коэффициенты[21] = 7;
    Коэффициенты[22] = 1;
 
    КонтрольнаяСумма = 0;
    Для А = 1 По 23 Цикл
        Число = Число(Сред(Строка, А, 1));
        КонтрольнаяСумма = КонтрольнаяСумма + Число * Коэффициенты[А - 1];
    КонецЦикла;
 
    КонтрольноеЧисло = КонтрольнаяСумма % 10;
 
    Возврат КонтрольноеЧисло = 0;
 
КонецФункции
С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.



ПроверитьРасчетныйСчет

оглавлениеПроверитьСНИЛС