ПроверитьКПП

оглавлениеРазложитьСтрокуВМассивПодстрок

ПроверитьОГРН (1С 8.3,8.2)

Функция выполняет проверку переданной строки с ОГРН на предмет корректности согласно алгоритму подсчёта контрольных сумм. Возвращает Истина, если Ок, иначе Ложь.

Функция ПроверитьОГРН(Знач Значение) Экспорт
 
    ОГРН = СокрЛП(Значение);
 
    Если Не ПопыткаПеревестиВЧисло(ОГРН) Тогда
        Возврат Ложь;
    КонецЕсли;    
 
    Если СтрДлина(ОГРН) = 13 Тогда
 
        Число = Число(Сред(ОГРН, 1, 12));
        Остаток = Число % 11;
        Если Остаток > 9 Тогда
            Остаток = Остаток % 10;
        КонецЕсли;
        Возврат Остаток = Число(Сред(ОГРН, 13, 1));
 
    ИначеЕсли СтрДлина(ОГРН) = 15 Тогда
 
        Число = Число(Сред(ОГРН, 1, 14));
        Остаток = Число % 13;
        Если Остаток > 9 Тогда
            Остаток = Остаток % 10;
        КонецЕсли;
        Возврат Остаток = Число(Сред(ОГРН, 15, 1));
 
    Иначе
        Возврат Ложь;
    КонецЕсли;
 
КонецФункции
С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.



ПроверитьКПП

оглавлениеРазложитьСтрокуВМассивПодстрок