ПроверитьКодыИФНС

оглавлениеПроверитьРегистрационныйНомерФСС

ПроверитьРегистрационныйНомерПФР (1С 8.3, 8.2)

Функция проверяет корректность строки с регистрационным номером организации в ПФР. Формат строки: xxx-xxx-xxxxxx.

Функция ПроверитьРегистрационныйНомерПФР(Знач Значение) Экспорт
 
    Номер = СокрЛП(Значение); // ххх-ххх-хххххх
 
    Части = РазложитьСтрокуВМассивПодстрок(Номер, "-");
 
    // часть 1 ххх
    Часть1 = СокрЛП(Части[0]);
 
    Если СтрДлина(Часть1) <> 3 Тогда
        Возврат Ложь;
    КонецЕсли;
 
    Если Не ПопыткаПеревестиВЧисло(Часть1) Тогда
        Возврат Ложь;
    КонецЕсли;
 
    // часть 2 ххх
    Часть2 = СокрЛП(Части[1]);
 
    Если СтрДлина(Часть2) <> 3 Тогда
        Возврат Ложь;
    КонецЕсли;
 
    Если Не ПопыткаПеревестиВЧисло(Часть2) Тогда
        Возврат Ложь;
    КонецЕсли;
 
    // часть 3 хххххх
    Часть3 = СокрЛП(Части[2]);
 
    Если СтрДлина(Часть3) <> 6 Тогда
        Возврат Ложь;
    КонецЕсли;
 
    Если Не ПопыткаПеревестиВЧисло(Часть3) Тогда
        Возврат Ложь;
    КонецЕсли;
 
    Возврат Истина;
 
КонецФункции
С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.



ПроверитьКодыИФНС

оглавлениеПроверитьРегистрационныйНомерФСС