Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

Процедура КнопкаВыполнитьНажатие(Кнопка)
 
    /// Как скопировать файл (ftp, http, https) в 1с 8.3, 8.2
 
    ФайлИсточник = "c:\\file_src.txt";
    ФайлПриемник = "c:\\file_dest.txt";
    КопироватьФайл(ФайлИсточник, ФайлПриемник);
 
    /// Как найти файлы в каталоге (ftp) в 1с 8.3, 8.2
 
    КаталоГдеИскать = "c:\\Documents";
    // возвращает значения типа Файл; поиск нерекурсивный
    МассивНайденныхФайлов = НайтиФайлы(КаталоГдеИскать, "*.txt");
    Для Каждого Файл Из МассивНайденныхФайлов Цикл
        Сообщить(Файл.Имя);
    КонецЦикла;
 
    /// Как переместить файл (ftp, http, https) в 1с 8.3, 8.2
 
    ФайлИсточник = "c:\\file_src.txt";
    ФайлПриемник = "c:\\file_dest.txt";
    ПереместитьФайл(ФайлИсточник, ФайлПриемник);
 
    /// Как удалить файл (ftp, http, https) в 1с 8.3, 8.2
 
    // если файл readonly - ошибка
    ФайлДляУдаления = "c:\\file_for_delete.txt";
    УдалитьФайлы(ФайлДляУдаления);
 
    КаталогДляУдаленияФайловИзНего = "C:\\Documents";
    // поиск нерекурсивный
    УдалитьФайлы(КаталогДляУдаленияФайловИзНего, "*.txt");
 
    /// Как создать каталог (ftp) в 1с 8.3, 8.2
 
    СоздатьКаталог("c:\\НовыйКаталог"); // каталог может уже существовать
    СоздатьКаталог("c:\\НовыйКаталог\\2\\3"); // создадутся все каталоги
 
    /// Как получить каталог временных файлов в 1с 8.3, 8.2
 
    Сообщить(КаталогВременныхФайлов());
 
    /// Как получить имя временного файла в 1с 8.3, 8.2
 
    Сообщить(ПолучитьИмяВременногоФайла()); // с расширением tmp
    Сообщить(ПолучитьИмяВременногоФайла(".txt")); // с расширением txt
 
    /// Как получить каталог программы в 1с 8.3, 8.2
 
    Сообщить(КаталогПрограммы());
 
    /// Как записать значение в файл в 1с 8.3, 8.2
 
    Массив = Новый Массив(1);
    Массив[0] = 10;
 
    ВременныйФайл = ПолучитьИмяВременногоФайла();
    ЗначениеВФайл(ВременныйФайл, Массив);
 
    /// Как восстановить значение из файла в 1с 8.3, 8.2
 
    КопияМассива = ЗначениеИзФайла(ВременныйФайл);
    Сообщить(КопияМассива[0]); // 10
 
    /// Как проверить существование файла в 1С 8.3, 8.2    
 
    КаталогНаДиске = Новый Файл("c:\windows");
    Если КаталогНаДиске.Существует() Тогда
    КонецЕсли;
 
КонецПроцедуры

Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

С уважением, (школа 1С программистов).

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).

Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.