Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

Полный синтаксис (нажмите, чтобы раскрыть)
Процедура КнопкаВыполнитьНажатие(Кнопка)
 
    /// Как создать соответствие в 1с 8.3, 8.2
 
    СобытияДаты = Новый Соответствие;
    // пара ключ (произвольного типа) - значение (произвольного типа)
    СобытияДаты.Вставить(1980, "Олимпиада в Москве");
    СобытияДаты.Вставить(1961, "Первый полет человека в космос.");
 
    /// Как получить значение соответствия по ключу в 1с 8.3, 8.2
 
    Сообщить(СобытияДаты.Получить(1980)); // "Олимпиада в Москве"
 
    /// Как узнать есть ли соответствие значения ключу в 1с 8.3, 8.2
 
    Если СобытияДаты.Получить(2014) = Неопределено Тогда
        Сообщить("В 2014 ничего не произошло.");
    КонецЕсли;
 
    /// Как изменить значение ключа созданного соответствия 
    /// в 1с 8.3, 8.2
 
    СобытияДаты.Вставить(1961, "Первый полет Гагарина в космос.");
 
    /// Как узнать количество элементов соответствия в 1с 8.3, 8.2
 
    Сообщить(СобытияДаты.Количество());
 
    /// Как обойти все элементы соответствия в 1с 8.3, 8.2
 
    Для Каждого Элемент Из СобытияДаты Цикл
        Сообщить(Строка(Элемент.Ключ) + " " + Элемент.Значение);
    КонецЦикла;
 
    /// Как удалить элемент соответствия в 1с 8.3, 8.2
 
    СобытияДаты.Удалить(1980);
 
    /// Как очистить все элементы соответствия в 1с 8.3, 8.2
 
    СобытияДаты.Очистить();
 
КонецПроцедуры

Если вы начинающий разработчик - вступайте в мою группу помощник программиста 1С. В ней мы обсуждаем вопросы программирования в 1С для начинающих (Владимир Милькин, школа программирования).

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

Библиотека Запросы ПрикладныеОбъекты УниверсальныеФункции

Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)