Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

ОбщиеОбъекты Запросы ПрикладныеОбъекты УниверсальныеФункции

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать)

Полный синтаксис (нажмите, чтобы раскрыть)

&НаКлиенте
Процедура ВыполнитьКод(Команда)
 
    /// Как создать соответствие в 1с 8.3, 8.2
 
    СобытияДаты = Новый Соответствие;
    // пара ключ (произвольного типа) - значение (произвольного типа)
    СобытияДаты.Вставить(1980, "Олимпиада в Москве");
    СобытияДаты.Вставить(1961, "Первый полет человека в космос.");
 
    /// Как получить значение соответствия по ключу в 1с 8.3, 8.2
 
    Сообщить(СобытияДаты.Получить(1980)); // "Олимпиада в Москве"
 
    /// Как узнать есть ли соответствие значения ключу в 1с 8.3, 8.2
 
    Если СобытияДаты.Получить(2014) = Неопределено Тогда
        Сообщить("В 2014 ничего не произошло.");
    КонецЕсли;
 
    /// Как изменить значение ключа созданного соответствия 
    /// в 1с 8.3, 8.2
 
    СобытияДаты.Вставить(1961, "Первый полет Гагарина в космос.");
 
    /// Как узнать количество элементов соответствия в 1с 8.3, 8.2
 
    Сообщить(СобытияДаты.Количество());
 
    /// Как обойти все элементы соответствия в 1с 8.3, 8.2
 
    Для Каждого Элемент Из СобытияДаты Цикл
        Сообщить(Строка(Элемент.Ключ) + " " + Элемент.Значение);
    КонецЦикла;
 
    /// Как удалить элемент соответствия в 1с 8.3, 8.2
 
    СобытияДаты.Удалить(1980);
 
    /// Как очистить все элементы соответствия в 1с 8.3, 8.2
 
    СобытияДаты.Очистить();
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать)

Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

ОбщиеОбъекты Запросы ПрикладныеОбъекты УниверсальныеФункции

С уважением, (школа 1С программистов).



Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться: