Условный оператор Если в языке 1С 8.3, 8.2 (в примерах)

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

ОбщиеОбъекты Запросы ПрикладныеОбъекты УниверсальныеФункции

См. урок для начинающих по условной команде в 1С
Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать)
Смотреть видео с демонстрацией выполнения кода

Полный синтаксис (нажмите, чтобы раскрыть)

&НаКлиенте
Процедура ВыполнитьКод(Команда)
 
    /// Как составить оператор Если в 1с 8.3, 8.2
 
    Если 1 > 0 Тогда // Истина
        // блок операторов
        Сообщить("Компьютер выполнит все команды из этого блока.");
        Сообщить("Один больше нуля.");
    КонецЕсли;
 
    Если 1 < 0 Тогда // Ложь
        Сообщить("Один меньше нуля.");
    Иначе
        Сообщить("Сработает именно эта ветка условного оператора (#А).");
        Сообщить("Один больше нуля.");
    КонецЕсли;
 
    Если 1 < 0 Тогда // Ложь
        Сообщить("Один меньше нуля.");
    ИначеЕсли 1 = 0 Тогда // Ложь
        Сообщить("Один равен нулю.");
    Иначе
        Сообщить("Сработает именно эта ветка условного оператора (#Б).");
        Сообщить("Один больше нуля.");
    КонецЕсли;
 
    /// Как составить тернарный оператор ? в 1с 8.3, 8.2
 
    Текст = ?(1 > 2, "Один больше двух.",  "Один не больше двух.");
    Сообщить(Текст); // выведет "Один не больше двух."    
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать)

Условный оператор Если в языке 1С 8.3, 8.2 (в примерах)

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

ОбщиеОбъекты Запросы ПрикладныеОбъекты УниверсальныеФункции

С уважением, (школа 1С программистов).



Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться: