Устанавливаем нужную версию .Net Framework для Обновлятора-1С

У вас есть что добавить?

Для своей работы программа Обновлятор-1С требует, чтобы на компьютере была установлена библиотека Microsoft .Net Framework 3.5.

Это стандартная библиотека, которая идёт по умолчанию со всеми современными версиями Windows, но обновлятор для совместимости использует одну из ранних версий этой библиотеки, которая может быть не установлена на вашем компьютере по умолчанию.

В зависимости от версии вашей ОС есть нюансы установки, о которых я расскажу ниже.

Способ первый

Прежде всего пробуем просто запустить установленный Обновлятор-1С. Если у нас Windows 8 и выше, то операционная система сама предложит скачать и установить нужную версию .Net Framework.

Если же у нас старая версия ОС, то пробуем скачать и установить .Net Framework 3.5 самостоятельно, вот по этой ссылке на сайте Microsoft.

Способ второй

Если установка первым способом не удалась, то бьюсь об заклад - у вас или Windows 10 или Windows Server 2016 или Windows Server 2012 R2.

В этих ОС установка .Net Framework 3.5 делается несколько иначе. В них эту библиотеку нужно включить в компонентах системы и уже затем скачать через центр обновления Windows.

Windows Server 2016 (2012 R2)

Вот как это делается для Windows Server 2016 (2012 R2), но обратите внимание, что в момент установки на компьютере:

  • должна быть включена служба обновлений Windows
  • должен быть включен интернет

Windows 10

Вот как это делается для Windows 10, но обратите внимание, что в момент установки на компьютере также:

  • должна быть включена служба обновлений Windows (об этом есть в ролике ниже)
  • должен быть включен интернет