[Alimir_BootModal_Login]

Внутренний язык программирования 1С 8.3 для начинающих программистов: циклы в 1С часть 2

Автор уроков и преподаватель школы: Владимир Милькин

На прошлом занятии мы изучили первый из двух существующих в языке 1С циклов: Цикл Для.

Сегодня нас ждет второй вид цикла: Цикл Пока.

Цикл Пока

Конструкция цикла выглядит так:

Пока ЛогическоеВыражение Цикл
  Команда1();
  Команда2();
  ...
КонецЦикла;

Команды, заключенные между словами Цикл и КонецЦикла выполняются пока ЛогическоеВыражение равно Истине.

В качестве логического выражения может быть любое условие. Пока это условие верно (то есть равно Истина) выполнение команд в цикле повторяется снова и снова, как только условие перестало быть верным команды перестают выполняться.

Решение задачи вывода чисел от 1 до 10, с применением только что изученного цикла, будет выглядеть так:

Шаг = 1;
Пока Шаг <= 10 Цикл
    Сообщить(Шаг);
    Шаг = Шаг + 1;
КонецЦикла;

Компьютер встретив такую конструкцию выполняет её так:

Порядок выполнения цикла компьютером

Задание №23. Измените приведенный выше пример, чтобы выводились числа от 10 до 100.

Не торопитесь смотреть ответ! Сначала попробуйте выполнить задание сами.

Ответ

Напоминаю, что все примеры из заданий нужно обязательно выполнять на компьютере. Вы читаете ознакомительную версию урока, полноценные уроки находятся здесь.

А как вы думаете сколько раз выполнятся следующие циклы:

Пока Истина Цикл
    Сообщить("Привет!");
КонецЦикла;
 
Пока 1 = 1 Цикл
    Сообщить("Привет!");
КонецЦикла;
 
Пока "Мир" = "Мир" Цикл
    Сообщить("Привет!");
КонецЦикла;

Не торопитесь выполнять эти примеры на компьютере! Ведь это, так называемые, бесконечные циклы. Которые начав выполняться - никогда не закончатся, потому что их логическое условие всегда равно Истина.

А вот следующие примеры можно смело пробовать на компьютере:

Пока Ложь Цикл
    Сообщить("Прощай!");
КонецЦикла;
 
Пока 1 = 2 Цикл
    Сообщить("Прощай!");
КонецЦикла;
 
Пока "Мир" = "Земля" Цикл
    Сообщить("Прощай!");
КонецЦикла;

Ведь эти циклы являются примерами бесполезных. Они никогда не выполнятся, потому что их логическое условие всегда равно Ложь.

Задание №24. Напишите программу, которая выводит на экран числа от 10 до 1, используя Цикл Пока. Вы читаете ознакомительную версию урока, полноценные уроки находятся здесь. Программа должна занимать ровно пять строк.

Ниже привожу решение, но рассчитываю, что вы справитесь с задачей самостоятельно.

Решение

Пройдите тест

Вопросы задаются по следующему примеру:

Шаг = 1;
Пока Шаг < 10 Цикл
    Сообщить(Шаг);
    Шаг = Шаг + 1;
КонецЦикла;
Начать тест