Основы запросов в языке 1С 8.3, 8.2 (в примерах)

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

<<< Основы Группировка Условия Упорядочивание Функции
<<< Итоги Соединение Объединение Параметры

См. урок для начинающих по основам синтаксиса языка запросов

/// Как запросить все строки со значениями всех столбцов 
/// из таблицы в 1с 8.3, 8.2
 
Процедура ЗапросВсехСтрокСоЗначениямиВсехСтолбцовТаблицы()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ
        |   *
        | ИЗ
        |   Справочник.Номенклатура
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры
 
/// Как запросить все строки со значениями определенных столбцов 
/// в 1с 8.3, 8.2
 
Процедура ЗапросВсехСтрокСоЗначениямиОпределенныхСтолбцовТаблицы()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ
        |   Код, Наименование, Родитель
        | ИЗ
        |   Справочник.Номенклатура
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры
 
/// Как использовать в запросах псевдонимы для столбцов и таблиц 
/// в 1с 8.3, 8.2
 
Процедура ИспользованиеПсевдонимов()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ
        |   Товары.Наименование КАК Имя, Товары.Родитель КАК Группа
        | ИЗ
        |   Справочник.Номенклатура КАК Товары
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры
 
/// Как добавить в результат запроса столбец с определенным 
/// значением в 1с 8.3, 8.2
 
Процедура ДобавлениеВРезультатЗапросаСтолбцаСОпределеннымЗначением()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ
        |   Наименование, 10000 КАК Цена, ""Оранжевый"" КАК Цвет
        | ИЗ
        |   Справочник.Номенклатура
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры
 
/// Как запросить неповторяющиеся (различные) строки из таблицы
/// в 1с 8.3, 8.2
 
Процедура ЗапросРазличныхСтрокИзТаблицы()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ РАЗЛИЧНЫЕ
        |   Родитель
        | ИЗ
        |   Справочник.Номенклатура
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры
 
/// Как запросить первые N строк из таблицы в 1с 8.3, 8.2
 
Процедура ЗапросПервыхНСтрокИзТаблицы()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ ПЕРВЫЕ 10
        |   Наименование
        | ИЗ
        |   Справочник.Номенклатура
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры
 
/// Как выбрать строки из таблицы в соотв-ми с правами 
/// пользователя в 1с 8.3, 8.2
 
Процедура ВыборкаРазрешенныхСтрокИзТаблицы()
    Запрос = Новый Запрос(
        "
        | ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |   *
        | ИЗ
        |   Справочник.Номенклатура
        |"
    );
 
    Результат = Запрос.Выполнить();
    ОткрытьЗначение(Результат.Выгрузить(ОбходРезультатаЗапроса.Прямой));
КонецПроцедуры

Основы запросов в языке 1С 8.3, 8.2 (в примерах)

<<< Основы Группировка Условия Упорядочивание Функции
<<< Итоги Соединение Объединение Параметры

С уважением, (школа 1С программистов).



Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.